• HDU 1856 More is better


    More is better

    Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
    Total Submission(s): 5725    Accepted Submission(s): 2127


    Problem Description
    Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

    Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
     
    Input
    The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
     
    Output
    The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.
     
    Sample Input
    4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
     
    Sample Output
    4 2
    Hint
    A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
     
    Author
    lxlcrystal@TJU
     
    Source
     
    Recommend
    lcy
     


    Statistic | Submit | Discuss | Note

    //因为A,B比较大,所以数据要进行处理,因为n在100000以内,所以开个200000左右的数组,将A,B进行从新编号,然后再进行并查集处理,求最大连通块

    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #include <algorithm>
    #define N 200003
    using namespace std;
    struct node
    {
        int a,b;
    };
    node te[100003];
    int n,m,Max;
    int f[N],t[N],r[N];
    int st[N];
    int bf(int x)
    {
        int l=1,r=m,mid;
        while(l<=r)
        {
           mid=(l+r)>>1;
           if(st[mid]>x) r=mid-1;
           else if(st[mid]<x) l=mid+1;
                else
                 return mid;
        }
    }
    int find_f(int x)
    {
        if(x!=f[x])
        {
            return f[x]=find_f(f[x]);
        }
        return x;
    }
    void union_set(int x,int y)
    {
        x=find_f(x);
        y=find_f(y);
        if(x==y) return;
        if(r[x]>r[y])
            {
                f[y]=x;
                t[x]+=t[y];
                if(t[x]>Max) Max=t[x];
            }
        else if(r[x]<r[y])
             {
                 f[x]=y;
                 t[y]+=t[x];
                 if(t[y]>Max) Max=t[y];
             }
             else
             {
                f[y]=x;
                r[x]++;
                t[x]+=t[y];
                if(t[x]>Max) Max=t[x];
             }
    }
    int main()
    {
        int i,j,a,b;
        while(scanf("%d",&n)!=EOF)
        {
            if(n==0)          //开始这里没有处理,WA一次
            {printf("1\n");continue;}
            j=1;Max=0;
          for(i=1;i<=n;i++)
           {
               scanf("%d%d",&te[i].a,&te[i].b);
               st[j]=te[i].a;j++;
               st[j]=te[i].b;j++;
           }
           j=2*n;
           sort(st+1,st+j+1);//调试时这里写了东西忘记删除、WA一次、悲剧
           m=1;
           for(i=2;i<=j;i++)
           {
               if(st[i]!=st[i-1])
                 st[++m]=st[i];
           }
           for(i=1;i<=m;i++)
            f[i]=i,r[i]=0,t[i]=1;
          for(i=1;i<=n;i++)
          {
              a=bf(te[i].a);
              b=bf(te[i].b);
              union_set(a,b);
          }
          printf("%d\n",Max);
        }
        return 0;
    }

  • 相关阅读:
    八数码问题--bfs
    子集生成——增量构造法
    回溯法
    子集生成——二进制法
    子集生成
    dfs 记忆搜索——注意剪枝方式
    pyhon---信息的爬取与提取---bs4,BeautifulSoup,re库
    008sudo用户管理
    007Linux在线升级yum
    006NFS与TFTP服务器
  • 原文地址:https://www.cnblogs.com/372465774y/p/2584138.html
Copyright © 2020-2023  润新知