• poj 2244(约瑟夫环)


    比较基础的约瑟夫环

    记住约瑟夫环的递推的公式  就行了

    假设是从0-n-1, 从0开始的第k个人

    f[1]=0;

    f[i]=(f[i-1]+k+1)%i  (i>1) 

    Eeny Meeny Moo
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 2927   Accepted: 2013

    Description

    Surely you have made the experience that when too many people use the Internet simultaneously, the net becomes very, very slow. 
    To put an end to this problem, the University of Ulm has developed a contingency scheme for times of peak load to cut off net access for some cities of the country in a systematic, totally fair manner. Germany's cities were enumerated randomly from 1 to n. Freiburg was number 1, Ulm was number 2, Karlsruhe was number 3, and so on in a purely random order. 
    Then a number m would be picked at random, and Internet access would first be cut off in city 1 (clearly the fairest starting point) and then in every mth city after that, wrapping around to 1 after n, and ignoring cities already cut off. For example, if n=17 and m=5, net access would be cut off to the cities in the order [1,6,11,16,5,12,2,9,17,10,4,15,14,3,8,13,7]. The problem is that it is clearly fairest to cut off Ulm last (after all, this is where the best programmers come from), so for a given n, the random number m needs to be carefully chosen so that city 2 is the last city selected. 

    Your job is to write a program that will read in a number of cities n and then determine the smallest integer m that will ensure that Ulm can surf the net while the rest of the country is cut off.

    Input

    The input will contain one or more lines, each line containing one integer n with 3 <= n < 150, representing the number of cities in the country. 
    Input is terminated by a value of zero (0) for n.

    Output

    For each line of the input, print one line containing the integer m fulfilling the requirement specified above.

    Sample Input

    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    0
    

    Sample Output

    2
    5
    2
    4
    3
    11
    2
    3
    8
    16
    

    Source

    #include <stdio.h>
    #include <string.h>
    
    
    int main()
    {
    	int n;
    	while(scanf("%d",&n)&&n)
    	{
    		int  i;
    		for(i=0;;i++) // 每隔i个报数
    		{
    			int s=0;
    			for(int j=2;j<=n-1;j++)
    			{
    				s=(s+i+1)%j;
    			}
    			if(s==0) break;
    		}
    		printf("%d\n",i+1);
    	}
    	return 0;
    }
  • 相关阅读:
    js 实现页面局部(或图片)放大功能(vue)
    momentjs 使用总结
    VUX的使用方法(以弹出框为例)
    vue alert插件(标题为图片)(自写)
    vue 五星评价插件
    ES6 学习笔记(基础)
    SVG
    纯 CSS 实现实心三角形和空心三角形
    selectedIndex和onchange事件
    DOM文档获取和简介
  • 原文地址:https://www.cnblogs.com/chenhuan001/p/3050095.html
Copyright © 2020-2023  润新知