• poj3280(Cheapest Palindrome)


    Description

    Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

    Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two different IDs ("abcb" and "bcba").

    FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

    Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

    Input

    Line 1: Two space-separated integers: N and M
    Line 2: This line contains exactly M characters which constitute the initial ID string 
    Lines 3.. N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

    Output

    Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

    Sample Input

    3 4
    abcb
    a 1000 1100
    b 350 700
    c 200 800

    Sample Output

    900

    Hint

    If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.

    对字符串进行增减字符,使之成为回文串,要求花费最少。典型的dp,dp[i][j]表示s[i...j]所需最小花费,则s[i]=s[j]时,dp[i][j]=dp[i+1][j-1],否则dp[i][j]=min(dp[i+1][j]+w[s[i]],dp[i][j-1]+w[s[j]])

    #include <iostream>
    #include <sstream>
    #include <fstream>
    #include <string>
    #include <map>
    #include <vector>
    #include <list>
    #include <set>
    #include <stack>
    #include <queue>
    #include <deque>
    #include <algorithm>
    #include <functional>
    #include <iomanip>
    #include <limits>
    #include <new>
    #include <utility>
    #include <iterator>
    #include <cstdio>
    #include <cstdlib>
    #include <cstring>
    #include <cctype>
    #include <cmath>
    #include <ctime>
    using namespace std;
    typedef long long LL;
    const int INF = 0x3f3f3f3f;
    const double PI = acos(-1.0);
    const double EPS = 1e-8;
    const int MAXN = 2010;
    int dx[] = {0, 1, 0, -1}, dy[] = {-1, 0, 1, 0};
    
    int dp[MAXN][MAXN], w[30];
    char s[MAXN];
    
    int main()
    {
        int n, m;
        cin >> n >> m;
        scanf("%s", s);
        getchar();
        while (n--)
        {
            char c;
            int a, b;
            scanf("%c%d%d", &c, &a, &b);
            getchar();
            w[c-'a'] = min(a, b);
        }
        for (int h = 1; h < m; ++h)
            for (int i = 0; i+h < m; ++i)
            {
                int j = i + h;
                if (s[i] == s[j])
                    dp[i][j] = dp[i+1][j-1];
                else
                    dp[i][j] = min(dp[i][j-1]+w[s[j]-'a'], dp[i+1][j]+w[s[i]-'a']);
            }
        cout << dp[0][m-1] << endl;
        return 0;
    }


  • 相关阅读:
    微软并行编程类库Parallel Extensions初探 Part1 (转)
    一些很酷的.Net技巧(上)
    【Silverlight】Silvelright端获取托管web项目中xap的路劲
    【Silverlight】Silvelright获取web端的xml
    博客开始第一天
    asp.net过滤HTML方法
    程序员应该懂的道理
    生成缩略图
    转:用自定义IHttpModule实现URL重写
    android 之helloword
  • 原文地址:https://www.cnblogs.com/godweiyang/p/12203977.html
Copyright © 2020-2023  润新知